Kan ik een andere PHP-versie gebruiken?

Hosting 2GO biedt ondersteuning voor verschillende PHP-versies. Op onze servers zijn de versies 5.2, 5.3, 5.5 en 5.6 beschikbaar.

Je kunt zelf dus kiezen welke versie je wilt gebruiken. Op onze hostingpakketten is standaard PHP-versie 5.3 ingesteld.

PHP instellen met de PHP Configurator

In het Control Panel kun je eenvoudig de PHP-versie instellen voor je hele hostingpakket. Onder Diensten vind je de knop voor de PHP Configurator. Vervolgens kun je jouw domein of subdomein selecteren met het pulldown-menu. Kies de gewenste PHP-versie en klik op OK.

PHP Configurator in het Control Panel

Je vindt de PHP Configurator in het Control Panel onder Diensten.

PHP Configurator instellen

Selecteer in de PHP Configurator eerst het gewenste domein/subdomein en kies dan de PHP-versie.


PHP instellen met .htaccess

Je kunt ook PHP instellen via .htaccess

PHP 5.2 instellen

Wanneer je versie 5.2 wilt gebruiken om .php-bestanden uit te voeren, kun je dat met een .htaccess bestand zelf aangeven, door hier de volgende regel in op te nemen:

AddHandler x-httpd-php5 .php
PHP 5.5 instellen

Wanneer je php-versie 5.5 wilt gebruiken om .php-bestanden uit te voeren, kun je dat met een .htaccess bestand zelf aangeven, door hier de volgende regel in op te nemen:

AddHandler x-httpd-php55 .php
PHP 5.6 instellen

Wanneer je versie 5.6 wilt gebruiken om .php-bestanden uit te voeren, kun je dat met een .htaccess bestand zelf aangeven, door hier de volgende regel in op te nemen:

AddHandler x-httpd-php56 .php

PHP instellen via .htaccess

Onderstaand stappenplan kun je gebruiken om een nieuw bestand met de naam .htaccess aan te maken waarbij we als voorbeeld PHP 5.5 activeren:

1
Login in het Control Panel en kies de gewenste domeinnaam
2
Klik op de knop “Bestandsbeheer”
PHP versie wijzigen via htaccess

Ga in het Control Panel naar “Bestandsbeheer”

3
Klik op de mapnaam “httpdocs”
4
Klik op de knop “Nieuw bestand”
5
Voer bij het vak “Bestandsnaam” de naam “.htaccess” in (zonder aanhalingstekens, beginnend met een punt!)
Geef het bestand een naam

De naam van het bestand begint met een punt; “.htaccess”

6
Voer in het nieuwe tekstvak de tekst “AddHandler x-httpd-php55 .php” in (zonder aanhalingstekens)
De juiste PHP versie instellen

Stel de juiste PHP-versie in met de eerder genoemde regel.

7
Klik op OK.

Vanaf nu worden alle .php bestanden in de httpdocs map (en de onderliggende mappen) uitgevoerd door PHP 5.5.

Belangrijke informatie
Kijk eerst of er niet al een bestand met de naam .htaccess op het hostingpakket staat. In de meeste FTP-programma’s wordt dit bestandstype uit veiligheidsoverwegingen niet getoond. Je kunt dit daarom het best controleren met Bestandsbeheer in het Control Panel.

Je vraag niet beantwoord?

Neem contact op met de helpdesk.
We helpen je graag verder.